Telefonie Hotline
Incident Report for Green
Resolved
This incident has been resolved.
Posted Jun 01, 2022 - 13:04 CEST
Identified
Aktuell ist unsere Telefonie Hotline nur eingeschränkt verfügbar. Sie können uns per Mail unter anfrage@green.ch kontaktieren.

Wir danken für Ihr Verständnis.
Posted Jun 01, 2022 - 08:12 CEST
This incident affected: Green Customer Care Center (Green Hotline).