A fix has been implemented and we are monitoring the results.
Posted Sep 10, 2025 - 15:59 CEST
Investigating
Die telefonische Erreichbarkeit ist derzeit beeinträchtigt. Bitte verwenden Sie bei Fragen unser Kontaktformular unter https://www.green.ch/de/kontaktformular - Wir prüfen die Ursache mit unseren Technikern und bedauern die Unannehmlichkeiten.
Ihre Green --
Telephone availability is currently impaired. If you have any questions, please use our contact form at https://www.green.ch/en/contact-form. We are investigating the cause with our technicians and apologize for the inconvenience.
--
La joignabilité téléphonique est actuellement perturbée. Pour toute question, veuillez utiliser notre formulaire de contact à l'adresse https://www.green.ch/fr/formulaire-de-contact. Nous examinons la cause du problème avec nos techniciens et vous prions de nous excuser pour la gêne occasionnée.
--
Al momento la raggiungibilità telefonica è compromessa. Per qualsiasi domanda, vi preghiamo di utilizzare il nostro modulo di contatto all'indirizzo https://www.green.ch/de/kontaktformular. Verificheremo la causa con i nostri tecnici e ci scusiamo per il disagio.
Posted Sep 10, 2025 - 15:38 CEST
This incident affected: Green Customer Care Center (Green Hotline).